Operational
Degraded Performance
Partial Outage
Major Outage
Under Maintenance

Production, Mayo Clinic - Asset Uptime/CMMS Feed Down, Highest:111371

Incident Report for Public

Monitoring

A data fix has been deployed to the production environment and is currently undergoing internal testing.
Posted Aug 12, 2026 - 12:05 UTC

Identified

It has been confirmed that the Asset Uptime Mayo Clinic feed is now up and running. However, we are observing additional data issues, specifically that operational assets are being displayed as hard down.
The engineering team is currently investigating whether this is a side effect of the recent fix or a new issue.
Posted Aug 12, 2026 - 12:05 UTC

Investigating

The Mayo Clinic data feed has not been updated since March 16. As a result, there are Work Orders and Work Order updates not present in the UI application.
Posted Aug 12, 2026 - 12:05 UTC
This incident affects: PS.Com.